thread: First Cycle after Implanon Removal, TTC and confused!

  1. #1
    Registered User
    Add IsisNephara on Facebook Follow IsisNephara On Twitter

    Sep 2013
    Sydney
    2

    First Cycle after Implanon Removal, TTC and confused!

    Long story short, Implanon removed 9th August, LMP before that was 14th July. Ultrasound on 6th Aug showed corpus luteum cyst in left ovary, as of today no AF and a whole lot of positive OPK's the last week, chart shows a triphasic pattern that you can see here My Ovulation Chart



    Not sure what to make of any of it anymore because we thought I had ovulated on the 29th August, but it appears I'm ovulating again.

    Any idea how long approximately it takes to AF on first cycle, or what the heck seems to be happenning?

  2. #2
    BellyBelly Member

    Aug 2013
    Canberra, ACT
    132

    Have you done a HPT? Because to me the temps almost look like BFP rise in temps... Did you have long/erratic cycles before implanon? When I had mine removed I went straight back in to normal cycles.

  3. #3
    Registered User
    Add IsisNephara on Facebook Follow IsisNephara On Twitter

    Sep 2013
    Sydney
    2

    Have you done a HPT? Because to me the temps almost look like BFP rise in temps... Did you have long/erratic cycles before implanon? When I had mine removed I went straight back in to normal cycles.
    I have had two beta HCGs done and both came back as <5mui/ml - not pregnant, I even took another HPT today and it's still showing BFN. Last cycle I had was on the 14th of July, prior to that there was no menstruation at all for 9 months and my GP wasn't concerned at all and just put it down to the Implanon. After I had the implanon removed, I had some creamy brown spotting for 5 days a week exactly after removal but nothing since.

  4. #4
    BellyBelly Member

    Aug 2013
    Perth, WA
    85

    Hi isis, i was just wondering if you had any news yet? xxxxxxx