thread: What am I doing wrong?

  1. #1
    BellyBelly Member

    Apr 2009
    179

    What am I doing wrong?

    We have moved house and Ive gone from gas fan forced oven, to electric with no fan.

    The heating element is in the bottom of this oven.

    Every time I try to bake something in this oven, it burns on the bottom. Turning things help, but when its a cake or something, not so much, I end up with a burnt bottom every time.

    What am I doing wrong?!

  2. #2
    BellyBelly Member

    Jun 2005
    USA
    3,991

    Re: What am I doing wrong?

    Are you always preheating the oven? I find stuff burns in our oven if I don't preheat as I think the element must be cranked up while heating so if I put anything in at that stage it burns the bottom.

  3. #3
    BellyBelly Member
    Add sepata on Facebook

    Sep 2011
    Sydney
    615

    Re: What am I doing wrong?

    Out of curiosity is it a chef ebc5231w? Or similar?

  4. #4
    Moderator

    Oct 2004
    In my Zombie proof fortress.
    6,449

    Re: What am I doing wrong?

    Try placing higher up in the oven. Also get an oven thermometer to check what your oven is actually doing. I found mine has to be cranked up by 15 degrees, yours may need turning down.

  5. #5
    BellyBelly Member

    Apr 2009
    179

    Re: What am I doing wrong?

    Meow, yes I am preheating it. For at least 15 minutes, usually more though.

    Sepata - its a Westinghouse Kimberley, from what I have read on the internet it seems to be a problem across the board.

    Astrid - thanks, so far cooking much higher in the oven has helped. I will definitely see to getting a thermometer to check out what it is actually doing though.

    Very frustrating!

  6. #6
    BellyBelly Member

    May 2010
    Land of Dreams
    1,201

    Re: What am I doing wrong?

    Oh I feel your pain, ours does the same!!!
    Only trick that works for me is, to turn the temp down, lower then what the food needs to be cooked at, and bake it longer!

  7. #7
    BellyBelly Life Subscriber

    Aug 2003
    VIC
    985

    Re: What am I doing wrong?

    We had a cheap electric with no fan oven in the house we rented before we bought our house and it was exactly the same. Nothin I could do could make it cook we'll cause it was a piece of c****

  8. #8
    Administrator
    Add Rouge on Facebook

    Jun 2003
    Ubiquity
    9,922

    Re: What am I doing wrong?

    Sounds like a thermostat problem. I think you need someone to look at the oven.

  9. #9
    BellyBelly Life Subscriber

    Aug 2003
    VIC
    985

    Re: What am I doing wrong?

    Ours was put in brand new while we lived there. It was just the cheapest oven money could buy

  10. #10
    BellyBelly Member
    Add xXHopeXx on Facebook

    Jan 2010
    Penrith, NSW
    1,075

    Re: What am I doing wrong?

    Not sure if it could help, but it has with us before, I used to put an oven tray with nothing on it on the rack below where I was cooking the food, and had the good higher up. Seemed to help displace the uber hot rays or something and distribute it a bit better.

  11. #11
    Nothing like a cuddle from DD after a hard day's work!

    Oct 2007
    in my own world
    3,267

    Re: What am I doing wrong?

    My old oven did the same. I use to have to put the food i wanted to cook on top of another tray that had a water bath in it to prevent things from brning. Was so frustrating that i hardly used the oven.

    When the new one got installed we use it at least twice a week.

  12. #12
    BellyBelly Member

    Jul 2010
    Melbourne
    2,737

    Re: What am I doing wrong?

    Maybe thermostat? When we moved into this place last year we had to get our thermostat replaced. Works great now

  13. #13
    BellyBelly Member

    Apr 2009
    179

    Re: What am I doing wrong?

    I can't see anything being replace on it. So far so good with moving things upwards though.