Results 1 to 12 of 12

Thread: Uterine Infection post ceaser...anyone had one?

  1. #1

    Join Date
    Jul 2006
    Location
    Noosa Hinterland
    Posts
    704

    Red face Uterine Infection post ceaser...anyone had one?

    I was just wondering if anyone has had a Uterine Infection after their cesear? I rushed to the doctors last saturday night with temps and offensive blood loss and it was diagnosed to be a uternine infection from the wound on my uterus. Ive been put on antibiotics but it doesnt seem to be working. Although the temps have gone, my loss (small amount) is still quiet yuk. Im on ANOTHER course of antibiotics for Mastitis...yep im having good luck! haha, and it doesnt really seem to be helping the uterine infection either!! Im worried im going to have to go to hospital and go on IV antibiotics. So im just wondering if anyone else has had one that taken a while to recover from it??


  2. #2

    Join Date
    Feb 2003
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    8,980

    Default

    Moving to c/s forum
    Kelly xx

    Creator of BellyBelly.com.au, doula, writer and mother of three amazing children

    BellyBelly Birth & Early Parenting Immersion - Find out how to have a BETTER, more confident birth experience... guaranteed!
    Want To Be A Doula? Everything You Need To Know

  3. #3

    Join Date
    Jul 2006
    Location
    Noosa Hinterland
    Posts
    704

    Default

    Thanks kelly

  4. #4

    Join Date
    Jan 2005
    Location
    Down by the ocean
    Posts
    6,110

    Default

    Not me but my SIL had to go to hospital for IV antibiotics due to an infection after her c/sect. She was in a bad way for a couple of days.
    I hope you recover quickly.

  5. #5

    Default

    No, but I thought I did, turns out I had busted one of my internal stitches, that's why I had redness and pain and swelling. Hope you recover soon!

  6. #6

    Default

    Claire, I had an infection after I had Nathan, and it did take a while to get better. The fact that I was doing too much at the time probably had a lot to do with it. If at all possible SLOW DOWN... hugs hun.

  7. #7

    Default

    Yep both times. It was tops (not). I new what to look for this time. I started off with the shivers at night and then pain and nasty stuff but I made the appointment after the shivers and sure enough tested positive for the infection. I also got a urinary infection both times as well (this is the only time Ive ever had a urinary infection). They all took ages to get better, dunno why that is.

  8. #8

    Join Date
    Jul 2006
    Location
    In The Land Of Wonderful...
    Posts
    1,751

    Default

    Claire,

    I don't want to scare you but I just want to say as strongly as possible... STAY ON TOP OF IT xxx

    I had a huge infection after an emergency c/s with Luke (he's now 9yrs old) - and after going back a few times because I didn't think things were right, they treated me yet again and told me I was fine.

    It wasn't until a few yrs later that I was TTC #2 and had a lap to discover the reason why I wasn't falling pg.
    It turns out the infection wasn't treated properly, and had been dorment in there for about 3yrs

    Needless to say, I've had more surgeries, but am still TTC #2 - My tubes have been too damaged from the infection, and we're ready to go for IVF #5 after Christmas.

    I know I'm probably the extreme "That could never happen to me" case, but it has been a devastating blow 6yrs TTC and still no luck - all because of an infection, not anything to do with my body (especially after falling pg with Luke the very first cycle)

    Stay on top of it, and don't think all will be ok if your intuition is telling you otherwise - You don't want to end up like me

    Lots of hugs your way xxx

  9. #9

    Join Date
    Jun 2007
    Location
    Port Stevens NSW
    Posts
    663

    Default

    Holly that's just so sad I'm so sorry that happend to you I hope Santa brings you your wish!

  10. #10

    Join Date
    Jul 2006
    Location
    In The Land Of Wonderful...
    Posts
    1,751

    Default

    Thanks Tiff!

    I deal with it ok now (ask me again if we're unsuccessful after IVF#5! ), but it absolutely has been a nightmare!

    I didn't want to scare anyone, but you know.....

  11. #11

    Join Date
    Feb 2006
    Location
    Australia
    Posts
    1,092

    Default

    I had a infection during my labour, before I had an emergency c/s. I had a high temp & shaking. I think it was from the 8 + internals I had during labour. I was on IV antibiotics and took a course of abs when I left hospital. It cleared up quickly.

  12. #12

    Join Date
    May 2006
    Location
    Sydney
    Posts
    169

    Default

    I too got an infection after emergency c-section. The thing that bothered me the most was that no one believed me!! I was in agnony, unable to get up from sharp pain...they said "yes dear you have had a major operation" grrrrrrrrrrrrr then i had to be re-admitted into hospital one day after they discharged me (early mind you) and from then i underwent many tests to find out it was in fact a urine infection that was by then affecting my kidneys. If anyone is experiencing pain that they know is not right do not let them discharge u...i was silly..and ended up in emergency, in a wheel chair sitting in front of reception balling my eyes out coz no one would move me to the seats..whilst DH was on his way over.

Similar Threads

  1. Trainee Doulas Available: Please Post HERE
    By BellyBelly in forum Using Doulas & Private Midwives
    Replies: 2
    Last Post: June 5th, 2016, 05:11 PM
  2. Post Natal Depression after Miscarriage?
    By Sophia in forum Trying To Conceive after Miscarriage or Loss
    Replies: 12
    Last Post: June 19th, 2007, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •