Results 1 to 11 of 11

Thread: This is a bit weird - need some help please

  1. #1
    Snodgrass Guest

    Default This is a bit weird - need some help please

    I've only just started charting, so am a bit of a dunderhead about this #-o

    Years ago, my cycle was 39 days. I went off the pill at the end of April, had two exact 28 day cycles, then went back to really long ones (37-39 days). I would have thought I'd be ovulating around 22 October.



    I'm currently on CD14 and it looks like I just ovulated, so I'm a bit confused.


    But, I had absolutely no EWCM and it just stayed creamy and there was very little of it (I've actually never seen anything that looks like EWCM).

    Is it normal to have big temperature fluctuations like that without ovulation? I'm religious about taking my temperature at the same time every morning before I get up.

  2. #2

    Default

    Hi snodgrass

    the link you provided wasn't to your actual chart so it had to be removed, but feel free to put the link to your actual chart in though.

    Love

  3. #3
    Snodgrass Guest

    Default

    Oh, it looks like I can't do it. I just tried to add it to the chart gallery, but it wouldn't let me because it's not a full cycle.

    Oh well, just have to wait and see what happens I suppose. We're not TTCing yet - I was just trying to work out what was going on.

  4. #4
    *TamaraP* Guest

    Default

    Snodgrass - I didn't produce a lot of EWCM, instead I found the cycle just gone around "o" I had a creamy day, then watery, then creamy again. Hope this helps.

  5. #5
    Fee Guest

    Default

    I've never had a huge temp rise without it being from ovulation. Not everyone gets EWCM.

    And I thought you still should be able to show off your chart - you don't need a full cycle...

  6. #6
    Snodgrass Guest

    Default

    Quote Originally Posted by Fee
    I've never had a huge temp rise without it being from ovulation. Not everyone gets EWCM.

    And I thought you still should be able to show off your chart - you don't need a full cycle...
    Hmmm. I couldn't see how to do it. When I tried to add my chart to the gallery it just said it wasn't a full cycle and didn't add it. Maybe I'm just a bit of an IT dunce #-o Is there anywhere that tells me how to do it?

    I found a bit of EWCM today so it must have been ovulation, which means I can't be having a 39 day cycle this time, because I'm only on CD14.

  7. #7
    Snodgrass Guest

  8. #8

    Join Date
    Mar 2005
    Location
    Racsheree Melbourne
    Posts
    502

    Default

    Wholly cow! now that's a jump..

  9. #9
    Fee Guest

    Default

    Wow that's a huge rise! I'd say that's your O.

    (PS - you can change it to Celsius too if you want)

  10. #10
    Snodgrass Guest

    Default

    Well, today it was 36.25, so it says I ovulated on CD12.

    That is absolutely bizarre, because my last two cycles were really long - up to 39 days.

    So since I went off the pill I've had two x 28 day cycles, and two long ones and then ovulated early in this one :-k . Suppose it takes a while to settle down after being on the pill pretty much constantly for almost 16 years.

  11. #11
    Fee Guest

    Default

    I see it hasn't given you a solid line though - so FF is not certain.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •