Results 1 to 7 of 7

Thread: Can anyone please help....

  1. #1
    Karla83 Guest

    Default Can anyone please help....

    Hi,
    I'm new to the forum and was just wondering if anyone has experienced this:
    I have a pretty regular 25 day cycle and I have no idea when I O becuase this is the first cycle TTC. Normally I have EWCM around day 8 for about 4 days, but this cycle nothing...Until yesterday...Day 20!!
    Apologies for the TMI but my cervix last week was low and hard, but yesterday and today it is high, soft and wet...I have what feels like AF pains....but the pain I had earlier today was more like O pains that I experienced around the "middle" of my cycle about 2 months ago so I thought it was O pains (then the penny dropped and I realised what day it was).
    I have a little bit of watery mucus but not too much...Really don't know what's happening (in a little bit of pain)......Can anyone offer a suggestion.

    Sorry if I am confusing!



    Thanks for everyones help
    Karla
    _________________
    ME: 23
    DH: 29
    TTC # 1

  2. #2

    Join Date
    Oct 2006
    Location
    North Lakes, Brisbane
    Posts
    1,590

    Default

    Hi Karla

    All the signs seem to indicate you are ovulating (get BD'ing girl). When you first notice the EWCM, I think ovulation is about 2-3 days away.

    Are you just coming off the Pill or some other kind of contraceptive? Sometimes your cycles go a bit haywire after going off them.

  3. #3

    Join Date
    Oct 2006
    Location
    North Lakes, Brisbane
    Posts
    1,590

    Default

    Hi Karla (again)

    If you're unsure when you ovulate, can I suggest you start charting your temps through Fertility Friend? I found that really helped me during the first couple of months. It makes it very obvious when you ovulate.

  4. #4
    Karla83 Guest

    Default

    We have been BDing - I just find it strange that AF is only 4 days away.

    I have been off the pill since November and everything has been very normal and exactly 25 days for the last 4 cycles and I haven't had anything like this.

    I did an OPK yesterday and had a negative - BD'd anyway this morning so can't tell for certain if EWCM is still there.

    Fingers crossed taht we have timed it right

    ME: 23
    DH: 29
    TTC # 1
    Furbabies: Thomas 1 and Zack 5 months

  5. #5

    Join Date
    Oct 2006
    Location
    North Lakes, Brisbane
    Posts
    1,590

    Default

    Could the EWCM you've been getting be semen? It can stay in the body for a couple of days and can be quite confusing. EWCM stretches a lot more than semen.

    Good luck to you .....

  6. #6
    Karla83 Guest

    Default

    Hi,
    The EWCM I had yesterday (and it was only a very little bit) was before the BD'ing. I had heaps of CM last cycle when I should and this month I had nothing until the little bit yesterday (Day 20). My cervix being high is interesting - perhaps my body is just preparing for AF??!!?!!
    Who knows....I'm like clockwork until I am actually TTC - MURPHY'S LAW!!!

  7. #7

    Join Date
    Oct 2006
    Location
    North Lakes, Brisbane
    Posts
    1,590

    Default

    Hi Karla

    You actually sound like me and I even said EXACTLY the same thing to somone here about a week ago - that my cycles were perfect until I started TTC. I used to have textbook cycles - 28 days in length, 5 days AF and ovulating at day 14. Since TTC'ing my cycles range from 24-32 days and I ovulate anywhere between day 10-14. Weird I know, but I know what you are saying.

    I'd suggest keep BD'ing until AF shows up or your CM dries up.

    Good luck Karla

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •