Results 1 to 10 of 10

Thread: Mucuos Plug

  1. #1

    Join Date
    Oct 2007
    Location
    Eastern Wheatbelt WA
    Posts
    3,282

    Default Mucuos Plug

    Can someone please tell me what colour it is?


  2. #2

    Join Date
    Feb 2006
    Location
    melbourne
    Posts
    11,462

    Default

    mine looked like snot/ewcm clear-ish/yellowish, hard to destinguish between normal CM and the plug though, wasnt blood stained until transition

  3. #3

    Join Date
    Feb 2008
    Location
    Country Victoria
    Posts
    5,945

    Default

    google it in google images. Its gross but it will show u some pics. Is everything ok?????

  4. #4

    Join Date
    Feb 2008
    Location
    Country Victoria
    Posts
    5,945

    Default

    remember if you are losing your plug, doesnt mean u will go into labour.. it can re-grow (is that the right word?)

  5. #5

    Join Date
    Jul 2004
    Posts
    5,756

    Default

    Mine was a clear yellowy colour and looked a bit like snot i suppose. I lost it all about 2 weeks before i went into labour.

  6. #6

    Join Date
    Oct 2007
    Location
    Eastern Wheatbelt WA
    Posts
    3,282

    Default

    Oh yeah, not worried about it being my plug, as long as it is the plug and not something else. And yes your body keeps making it, just like Amniotic Fluid.

    I've been having a snotty like greyish colour for about 2-3 weeks now which I guess would be my plug.

    But this morning it's a greenish/yellowish greyish kind of colour. Same consistancy as the last few weeks.

  7. #7

    Join Date
    Feb 2008
    Location
    Country Victoria
    Posts
    5,945

    Default

    Mayb thrush or UTI???

  8. #8

    Join Date
    Feb 2006
    Location
    melbourne
    Posts
    11,462

    Default

    id say maybe an infection too, maybe just higher levels of bacteria in your vagina, id get a swap done and if you have some probiotics start taking them, i would definatly get it checked

  9. #9

    Join Date
    Oct 2007
    Location
    Eastern Wheatbelt WA
    Posts
    3,282

    Default

    Thanks, I thought so. Was kinding hoping I'd be wrong though.

  10. #10

    Join Date
    Jan 2007
    Location
    where cosmopolitans and margaritas flow all night
    Posts
    2,794

    Default

    Doesn't sound like the plug.
    I thought I'd lost mine a few days before I did. When I did lose it there was such a difference between what I thought it was and what it actually was. I was getting a lot of discharge for a few days but then one day I had a huge clump of yellow/white stuff that was enough to fill a dessert spoon and it all came out in one hit. I freaked out and rang my mum. She told me what it was. I was in labour 2 days later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •