Results 1 to 6 of 6

Thread: Question on implantation bleeding

  1. #1

    Join Date
    Mar 2005
    Location
    Sydney, NSW
    Posts
    3,352

    Default Question on implantation bleeding

    Hi, I have a question....Dh and I did the deed two weekends ago, it was the very end of my period. I had to get the morning after pill the next day... anyway, about 5 days after I had 2 days of very slight bleeding.
    My question is (and I pray it's not) is could it be implantation bleeding or is it just too early. We really don't want another bub, so Im pretty scared at the moment (somehow we would have to manage if I was pregnant, but I hope not). I am feeling nauseous but Im sure it's because Im scaring myself....
    any info would be greatly appreciated
    xoxo


  2. #2

    Join Date
    Nov 2004
    Location
    Western Australia
    Posts
    2,300

    Default

    Fingers crossed its the effects of the morning after pill Meg. It sounds a little bit too early for anything else.

    Jo

  3. #3

    Join Date
    Mar 2005
    Location
    Sydney, NSW
    Posts
    3,352

    Default

    I would've thought it too early too. Lets hope it was from the pill. Thanks for the input, think it's what I needed to hear! xo

  4. #4
    skorpy Guest

    Default

    Ovulation doesnt usually happen that early.It has been known though,so dont totally rule out the possability just because it was so soon after your period

    BUT.. if you took the morning after pill,the chances are that you are safe.

  5. #5

    Join Date
    Jul 2005
    Location
    Texas, USA
    Posts
    627

    Default

    Hey Meg! I think your system may just be off since you just started having your period pretty recently. I wouldnt be suprised if it took a couple months to regulate, especially since you are still bfing. That and all the stress with Coco being sick lately and everything can cause a bleed also. I have my fingers crossed for you! Try not to worry about it...at least for another month till you can be sure!

  6. #6

    Join Date
    Mar 2005
    Location
    Sydney, NSW
    Posts
    3,352

    Default

    thanks guys. Was only worried because I'd never had bleeding after MAP (have had it a couple of times over the years). Anyway, Im reassured now!! We're in a two bed unit with 4 of us, dont' think it's time for another bub!!! Mind you, if it's meant to be it's meant to be! I am pretty sure Im not pregnant, no symptoms now and with the other two had symptoms early. xoxo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •