Results 1 to 14 of 14

Thread: Brown discharge after internal?

  1. #1

    Default Brown discharge after internal?

    Hi Lovelies,



    Possible TMI...

    Just a quick question - I am sure everything is ok but just want to double check. When I went to the loo this morning there was brown on the toilet paper after I wiped. It looked like it was dry blood. There has been none since. I'm just wondering if this is likely to be a result of the (rather painful) internal I had at the Ob's yesterday? She didn't say she was going to do a stretch and sweep but it certaintly felt like she was attempting one! I also had cramping yesterday which I thought was just from the internal...

    TIA

    MG

  2. #2

    Join Date
    Aug 2005
    Location
    Wodonga, VIC
    Posts
    316

    Default

    Yeah it is all normal, I had this after both my S&S. Sorry to hear it was painful. It could also be part of your plug starting to come away if you haven't already lost it.
    Now would be a good time for those EPO's!
    HTH

  3. #3

    Join Date
    Oct 2006
    Location
    Sydney NSW
    Posts
    4,837

    Default

    I had that for 2 days with DD#2 and then had her on the 3rd day so it could be a sign you are on your way!

  4. #4

    Default

    Thanks Amanda! I thought it was normal but thought I had better just double check! DH has instructions to pick some EPO up on his way home! LOL

  5. #5

    Join Date
    Jun 2006
    Location
    Apparently in about 7 months I will be a qualified midwife - yikes!
    Posts
    1,248

    Default

    ooohhhhhh goodluck MG - I hope this means that bubba is not far away!

  6. #6

    Default

    Thanks girls! It would be so nice to avoid the induction! LOL - although my BF will be bitterly disappointed as it is her birthday on Thursday and she was hoping to share her birthday with her Godchild!

  7. #7

    Join Date
    Sep 2005
    Location
    South Coast NSW
    Posts
    1,260

    Default

    Hi MG im sure it was just some 'old' blood. When they gave me my internal a few weeks ago they said something about brown blood. If it was bright red and alot then worry. Also you will probably find that you will loose your plug soon, as internals can do that. I am still loosing mine......
    Love jen

  8. #8

    Join Date
    Nov 2005
    Location
    QLD
    Posts
    3,068

    Default

    MG
    As others have said its normal. Heres hoping that something happens very soon

  9. #9

    Default

    Thanks guys. I am waiting (im)patiently now for things to happen. Although there has been no more discharge or any other signs since this morning. Will just have to wait and see.... *sigh* Bring on the EPO!

  10. #10

    Join Date
    Feb 2006
    Location
    Newcastle, NSW
    Posts
    4,219

    Default

    I hope something happens for you soon MG
    Sending you loads of labour vibes!!!

  11. #11

    Join Date
    Sep 2004
    Location
    Sydney's Norwest
    Posts
    4,954

    Default

    MG, hoping your body gets things happenig for you soon hun. I used the EPO as I was going to bed, less chance of it running back out Remember to pad up too, it get's messy

  12. #12

    Join Date
    Feb 2006
    Location
    AUSTRALIA
    Posts
    1,263

    Default

    Hope its soon hun, and that your staying cool in the heat today and tomorrow

  13. #13

    Default

    Here's hoping little one isn't too far away. Can't wait to hear the good news.

  14. #14
    gigi01 Guest

    Default

    Hoping that it's all beginning MG - good luck! Look forward to the news....

    Gigi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •