Results 1 to 12 of 12

Thread: confused about mucus plug

  1. #1
    betty.boop1 Guest

    Question confused about mucus plug

    i have read the thread that tara posted about the mucus plug, but now Im a bit confused as I am 35 weeks and I pretty sure that I have not list mine yet. When does this usually happen and exactly what am I supposed to be looking for? Is it just like normal body fluid as mine has increased a little since pregnancy but nothing too different. Can someone help?


  2. #2

    Join Date
    Oct 2006
    Location
    Melbourne, Victoria
    Posts
    1,027

    Default

    I didn't lose mine until a couple of days before both labours. I think they can vary in description. Mine was very thick and was tinged with blood (sorry if TMI!). Don't worry if you haven't lost it yet, you still have a little while to go. Best of luck for a wonderful delivery.

  3. #3

    Join Date
    Feb 2007
    Location
    Coombabah
    Posts
    275

    Default

    It can happen anytime really. With DS it happened after my waters had broken at 39 weeks. With DD I never really saw it as I was induced so didnt take much notice.

    I am sure others will jump on and say there experiences etc. But I definitely wouldnt worry too much. There is no time set on when you should lose your musuc plug. I can remember it being like thick clear vaginal discharge globs. Hopefully someone who has been through it more recently then me will enlighten you some more.

    Goodluck Jac

  4. #4

    Join Date
    Sep 2006
    Location
    Dandy Ranges ;)
    Posts
    7,526

    Default

    I haven't lost mine yet, and my EDD is a week away!

  5. #5

    Join Date
    Jun 2006
    Location
    Gold Coast, Australia
    Posts
    1,618

    Default

    Pretty sure I'm losing mine at the moment - it is clear, stretchy, and in big globs, sometimes it has been pink or tinged with blood.

    Some people never notice if they lose theirs, so don't worry too much about it!

  6. #6

    Join Date
    Feb 2004
    Location
    Melbourne
    Posts
    11,171

    Default

    I lost mine the morning that I went into labour (at 1pm).

  7. #7

    Join Date
    Sep 2006
    Location
    Kids party house central - come on over!
    Posts
    249

    Default

    I lost mine the night i went into labour. It was a redcolour like a blob of blood. (sorry if that sounds yuk!)


    Jen

  8. #8

    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    2,614

    Default

    I lost mine on tuesday and Claire was born on the following saturday. She was born at 38.5 weeks. Mine looked like a big snot blob with some blood in it.

  9. #9

    Default

    LOL, big snot blob explains it well.

    With DS, I lost all mine at once when my waters broke and it was huge, browny clear glob.

    With DD and this pregnancy, I lost it in bits. Looks like clear gel globs that can't pull apart, sometimes with blood or discoloured.

  10. #10

    Join Date
    Feb 2005
    Location
    Mid North Coast NSW
    Posts
    2,504

    Default

    I lost mine about 2 days before my waters broke & contractions started.

    I wouldn't be worried at all. It may not come away until you are well into labour.

  11. #11

    Join Date
    Jul 2006
    Location
    Brisbane
    Posts
    3,205

    Default

    I didn't lose mine. I probably did when the OB broke my waters but I certainly didn't prior to labour or going to the hospital.

  12. #12

    Join Date
    Aug 2006
    Location
    Gold Coast
    Posts
    334

    Default

    with mya i lost mine the day she was born ~ 40weeks exactly ~. With Bodhi i lost bits & peices of it for about a week b4 he was born ~probably about 40weeks aswell since i was 7 days overdue ~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •