Page 1 of 2 12 LastLast
Results 1 to 18 of 26

Thread: Is this the mucus plug?

  1. #1

    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    2,614

    Default Is this the mucus plug?

    Hello,

    I just wanted to know if anyone could give me some advice on this? Sorry if its a bit tmi!

    I went to the bathroom earlier, and I had a big blob of mucus. It was like snot.
    There was no blood or anything, but I havent seen something like it before, so i dont know what its meant to be like.



    Could this be the start of my mucus plug or just a blob of normal CM??

  2. #2

    Join Date
    Mar 2006
    Location
    Brisbane
    Posts
    1,731

    Default

    Yeeeeessss!!!!!! Woohoo. Are you packed yet? Could still be a little while but yay! How exciting. Take care sweet and rest up!

  3. #3

    Join Date
    Feb 2004
    Location
    Melbourne
    Posts
    11,171

    Default

    Yep it could be a part of the plug, but isn't it more a bloody show that signals things are happening?

  4. #4

    Default

    Sounds like the plug, or the start of it anyway. With mine I didn't have any blood. I lost mine about a week before having Nina. I didn't have a bloody show until an hour before she was born.

  5. #5

    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    2,614

    Default

    Yay, at least I'm not a freak. DH reckons this baby is going to come late, so we'll see what happens I suppose. I just dont think I can talk to him about it, or tell him about it. He'll just tell me I am gross!

    Would I probably have a bloody show some time over the next couple weeks too?
    I'm so clueless.

  6. #6

    Join Date
    Jun 2006
    Location
    Apparently in about 7 months I will be a qualified midwife - yikes!
    Posts
    1,248

    Default

    I had a slightly slighty bloody streaked plug, I think the blood is just an indicator that your Cervix is starting to thin.

  7. #7

    Join Date
    Nov 2005
    Location
    QLD
    Posts
    3,068

    Default

    Yes sounds like the plug to me. Not too much longer to wait now

  8. #8

    Join Date
    Oct 2005
    Location
    A Nestle Free Zone... What about YOU?
    Posts
    5,374

    Default

    Karina,
    It's not uncommon to have what you describe and then a little later you may find some blood stained blobs!
    This is all GOOD and shows that wonderful body of yours is doing just what it should to get your baby into your arms!

  9. #9

    Default

    I didnt have a bloody show at first..... mine started on the monday... and the rest come out with blood tuesday night... DD was born weds morning

    All the best.... could b a bubba on its way very soon!!

  10. #10

    Default

    karina, sorry to jump in on your thread but just wanted to say thanks for asking this question!!i thought i lost my plug 5 days ago, but since nothing has happened was starting to doubt it(i never lost it with DS)..but mine was exactly as you described..so obviously it was..

    here's hoping we both have babies soon!!

    PS anyonee know how long it can be after losing plug to having baby??thankyou!!

  11. #11

    Join Date
    Mar 2006
    Location
    Getting to know Brisbane all over again
    Posts
    2,047

    Default

    Woohoo Karina - how exciting!

  12. #12

    Default

    I think it can be up to 2 weeks before??

    Correct me if im wrong-which is common!!

  13. #13

    Join Date
    Oct 2006
    Location
    Sydney
    Posts
    141

    Default

    One of my preggo books says the baby will usually make an appearance within a week of the show/plug!

    Fingers crossed!

  14. #14

    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    2,614

    Default

    Yay, thank for your replies everyone. I havent had any more "snot" so I guess I just get to sit around and wait now haha.

    Fletch, we dont know its sex so its sort of yellow at the moment...

    Christie, yay hope something happens for you soon!

  15. #15

    Join Date
    Nov 2005
    Location
    QLD
    Posts
    3,068

    Default

    Totalbabe

    It could have been your plug. Sometimes you can loose the plug and nothing happens for a few days or even a couple of weks. The other option is that you only lost part of your plug.

  16. #16

    Join Date
    Jun 2005
    Location
    Blue Mountains
    Posts
    5,086

    Default

    I was shocked at just how much plug there is... I even rang the midwives worried about it, and they said that there is quite a bit. hehe.

    I lost mine during my pre-labour diarrhoea, blobby & bloody.. so you can imagine the mess I was dealing with for 1 1/2 days! LOL.

  17. #17

    Join Date
    Jul 2006
    Location
    Berwick, Melbourne
    Posts
    947

    Default

    YAY for Karina. At least one of us has had something happen!

  18. #18

    Join Date
    Oct 2004
    Location
    Sydney
    Posts
    2,614

    Default

    Aww Rachel, I thought you had a bit of waters?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •