Results 1 to 7 of 7

Thread: not sure if it was just mucas (TMI)

  1. #1

    Join Date
    Dec 2007
    Location
    Adelaide, SA
    Posts
    903

    Default not sure if it was just mucas (TMI)

    Last night i went to the loo and discovered a large amount of mucus, it was clearish, very sticky and stretchy and had no odour, it was like a big blob, is this just normal discharge or could it be part of my plug.

    Ive never lost my plug before so have no idea what i should be looking for.


  2. #2

    Join Date
    Dec 2005
    Location
    In Bankworld with Barbara
    Posts
    14,235

    Default

    it does sound like your plug is starting to come away, but bare in mind that this can go on for weeks and isn't always an indicator that birth is not far away. I started losing mine at 37wks with my 4th baby and it started just like you have described.

  3. #3

    Join Date
    Nov 2007
    Location
    Melbourne
    Posts
    1,071

    Default

    Gonna get personal here but did you and DH DTD recently??

    I have heard that this happens up to a couple of days after DTD, its normal and not necessarily your plug.

    Just it sounds like the same thing that happens to me after getting some lurve

  4. #4

    Join Date
    May 2004
    Location
    Brisbane
    Posts
    1,814

    Default

    It does sound like a bit of your plug. Usually it means that your starting to dilate but with a second baby that doesn't mean you're going into labour any time soon Second time mums can be dilated for weeks with bits of plug coming away randomly.
    The plug can also regenerate as well.

  5. #5

    Join Date
    Feb 2008
    Location
    Country Victoria
    Posts
    5,945

    Default

    yep... one of my mates was losing her plug for 6 weeks!!! lol

  6. #6

    Join Date
    Dec 2007
    Location
    Adelaide, SA
    Posts
    903

    Default

    this is bub no 3 for me, so i gues it things happening slowly. I dont want to rush anything this little man needs to cook a bit longer.Im trying not to think about it too much as my DS was 1o days over.

    Smudgies mum I can only wish ......lol DH has been working long hours comes home and falls asleep.

  7. #7

    Join Date
    Jan 2007
    Location
    VIC
    Posts
    2,199

    Default

    I had this type of 'loss' for over 8 weeks before I gave birth. Not sure if it's necessarily the plug. Even if it is, I was informed that the plug can regenerate itself anyway. I agree that it's probably not the sign of an impending labour, but keep an eye on it Your body is def getting ready

Similar Threads

  1. Lost mucus plug??? Labor?? Alan your opinion?
    By 1st time mummy 2 be in forum Pregnancy - Third Trimester General Discussion
    Replies: 13
    Last Post: May 29th, 2007, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •